HOWTO

SwyxWare V6.20 requires Firmware upgrade of SwyxPhones (kb3925)

The information in this article applies to:

  • SwyxWare v6.20
  • SwyxWare v6.12
  • SwyxPhone L540
  • SwyxPhone L520s
  • SwyxPhone L440
  • SwyxPhone L400
  • SwyxPhone L420

[ Summary | Information | Links ]


Summary

For using SwyxWare from Version 6.20 with SwyxPhones of the L4xx or the L5xx series it is imperative that the firmware version 5.4.6.0 (sometimes also refered as V5 R4.6.0) or newer will be used.

We recommend checking the firmware of the SwyxPhones before updating SwyxWare to version 6.20. In case the firmware has not the required release you have to upgrade it before the update of SwyxWare.

Information

With the release of the SwyxWare v6.20 the DLS (Deployment and Licensing Server) protocol was implemented. This protocol is used for connecting the SwyxPhones L4xx/L5xx with the SwyxWare server. Due to this change it is mandatory to have the right firmware installed on the SwyxPhones and if required to perform an firmware upgrade to the necessary firmware.

Exception: The old SwyxPhone L420 (equals Siemens optiPoint 400 standard) can still be used with the Swyx Firmware 1.1.7. But please note that for this model no intensive testing is done any more for SwyxWare v6.20 or following versions.

 

Please consider the mentioned hints and the specific order when performing the updates.
From SwyxWare v6.02 MP2 a direct update to v6.20 can be performed. Start with Sequence B
SwyxWare older then v6.02 MP2 have to be updated first to a level that allows a further update to v6.20. In such a case please start with Sequence A.
Additional information on how to update the firmware of a SwyxPhone automatically can be found here:
SwyxWare Administrator documentation, in chapter 18.4.3.
Or use the Siemens Deployment-Tool.
 
Sequence A
Update of a SwyxWare version older then version 6.02 MP2:
Currently installed is a SwyxWare 5.0x or older
Please proceed as follows:
  1. Update of the SwyxWare to version 6.02
  2. Update of the SwyxWare to Version 6.02 MP2
  3. Please proceed with Sequence B, "Firmware-upgrade of the end devices and update of the SwyxWare from V6.12" (please see below)
 
Currently installed is a SwyxWare 6.0x
Please proceed as follows:
  1. Update of the SwyxWare to Version 6.02 MP2
  2. Please proceed with Sequence B, "Firmware-upgrade of the end devices and update of the SwyxWare from V6.12" (please see below)  
 
Currently installed is a SwyxWare 6.02 MP2
Please proceed as follows:
  1. Update is equivalent to the update from V6.12, Sequence B, "Firmware-upgrade of the end devices and update of the SwyxWare from V6.12" (please see below) 

                                  
Sequence B
Firmware-Upgrade
of the end devices and update of the SwyxWare from V6.12 (V6.02 MP2):
Currently installed is a SwyxWare 6.12 and SwyxPhones with the firmware version 5.1.31
Please proceed as follows:
  1. Upgrade of the SwyxPhones to firmware version 5.4.6.0
        (please wait until the upgrade was performed on all SwyxPhones)
  2. Update to SwyxWare Ver6.20
 
Currently installed is a SwyxWare 6.12 and the SwyxPhones with the firmware version 5.1.32
Please proceed as follows:
  1. Upgrade of the SwyxPhones to firmware version 5.4.6.0
        (please wait until the upgrade was performed on all SwyxPhones)
  2. Update to SwyxWare Ver6.20 
Currently installed is a SwyxWare 6.12 and the SwyxPhones with the firmware version 5.1.35
Please proceed as follows::
  1. Downgrade the SwyxPhones to firmware version 5.1.32
        (either with the Siemens Deployment-Tool or manually via the Webbrowser)
  2. Upgrade of the SwyxPhones to firmware version 5.4.6.0
        (please wait until the upgrade was performed on all SwyxPhones)
  3. Update to SwyxWare Ver6.20
          (Background information: The Siemens firmware 5.1.35 is not capable in being upgraded therefore the firmware needs to be downgraded prior to the upgrade)

Hint:
Why do I have to wait for all SwyxPhones to be automatically upgraded?
The message „Firmwareupgrade notwendig“appears only in the display of the Phone if the user de-registered and registered himself on the server. The user has to confirm the firmware upgrade manually. If a user is not in the office due to a business travel, vacation or illness it is most likely that this SwyxPhone won’t be upgraded.
Therefore it is mandatory to check via the SwyxWare-Administration that all SwyxPhones do have the adequate firmware prior to the SwyxWare update to V6.20.

Links

As far as software supplied or used by us, includes open source elements the additional terms under https://www.swyx.com/open-source apply in addition. An overview which products from the Swyx portfolio include open source elements and which open source license is relevant can be found under https://www.swyx.com/open-source.

The third-party contact information included in this article is provided to help you find the technical support you need. This contact information is subject to change without notice. Swyx in no way guarantees the accuracy of this third-party contact information nor is responsible for it's content.


Comment

Comment on this article



If we have any follow-up questions, where can we contact you?

E-Mail Address (optional)


Note

This feedback form can't be used for support requests. Those requests must be directed to your Swyx reseller or distributor.